re = /^\d+(?:\.\d+)*$/im
str = '25.23.25
25.2323.5656.5656344444444444444444444444444444444444444444444444444444444444444444444444444444444444344444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444
25'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result