$re = '/(?:^fruits|(?<!^)\G)\h*\K(?<count>\d*)\h*(?<fruit>\w*)/m';
$str = 'fruits 5 apples, 2 oranges, 3 bananas
cars foo bar
fruits 8 apples, 2 oranges, 3 bananas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);