re = /(?:^fruits|(?<!^)\G)\h*\K(?<count>\d*)\h*(?<fruit>\w*)/m
str = 'fruits 5 apples, 2 oranges, 3 bananas
cars foo bar
fruits 8 apples, 2 oranges, 3 bananas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end