import re
regex = re.compile(r"(?:^fruits|(?<!^)\G)\h*\K(?<count>\d*)\h*(?<fruit>\w*)", flags=re.MULTILINE)
test_str = ("fruits 5 apples, 2 oranges, 3 bananas\n"
"cars foo bar\n"
"fruits 8 apples, 2 oranges, 3 bananas")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")