#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z]+(\((?:`[()]|[^()]|(?1))*\))"
Local $sString = "body(read.table)" & @CRLF & _
"sink()" & @CRLF & _
"try(try2())" & @CRLF & _
"try(try2() + try3() )" & @CRLF & _
"sink( backticks dont close the par`( )" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")