$re = '/[a-z]+(\((?:`[()]|[^()]|(?1))*\))/m';
$str = 'body(read.table)
sink()
try(try2())
try(try2() + try3() )
sink( backticks dont close the par`( )
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);