using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]+(\((?:`[()]|[^()]|(?1))*\))";
string input = @"body(read.table)
sink()
try(try2())
try(try2() + try3() )
sink( backticks dont close the par`( )
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}