#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{\\'([a-zA-Z])}"
Local $sString = "L{\'o}pez"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)