using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\\'([a-zA-Z])}";
string substitution = @"$1";
string input = @"L{\'o}pez";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}