$re = '/{\\\\\'([a-zA-Z])}/';
$str = 'L{\\\'o}pez';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;