package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([0-2][1-9]\.((0[1-9])|1[0-2]))|((3[0,1])\.((0[1,3-9])|(1[0-2]))))\.(\d{4})`)
var str = `11.01.2022
29.02.2022
.02.2022
99.99.2022
31.01.2021
30.01.2021`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}