import re
regex = re.compile(r"^(([0-2][1-9]\.((0[1-9])|1[0-2]))|((3[0,1])\.((0[1,3-9])|(1[0-2]))))\.(\d{4})", flags=re.MULTILINE)
test_str = ("11.01.2022\n"
"29.02.2022\n"
".02.2022\n"
"99.99.2022\n"
"31.01.2021\n"
"30.01.2021")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")