const regex = new RegExp('<Data>(?<data>[^<]*(?:<(?!/?Data>)[^<]*)*)</Data>', '')
const str = `<Data>Some text
etx.</Data>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}