re = /<Data>(?<data>[^<]*(?:<(?!\/?Data>)[^<]*)*)<\/Data>/
str = '<Data>Some text
etx.</Data>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end