$re = '~<Data>(?<data>[^<]*(?:<(?!/?Data>)[^<]*)*)</Data>~';
$str = '<Data>Some text
etx.</Data>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);