import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*[^*]*(?=\\*\\{:term\\})";
final String string = "* *Pivot Row*{:term}\n"
+ "This is another term *Pivot Row*{:term}\n"
+ "* **List**: This is another term *Pivot Row*{:term}\n"
+ "*This* is *another* term repetition *Pivot Row*{:term}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}