re = /\*[^*]*(?=\*\{:term})/m
str = '* *Pivot Row*{:term}
This is another term *Pivot Row*{:term}
* **List**: This is another term *Pivot Row*{:term}
*This* is *another* term repetition *Pivot Row*{:term}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end