$re = '/\*[^*]*(?=\*\{:term})/m';
$str = '* *Pivot Row*{:term}
This is another term *Pivot Row*{:term}
* **List**: This is another term *Pivot Row*{:term}
*This* is *another* term repetition *Pivot Row*{:term}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);