package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#\w+`)
var str = `#food was testy. #drink lots of. #night was fab. #three #four`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}