$re = '/#\w+/';
$str = '#food was testy. #drink lots of. #night was fab. #three #four';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);