re = /#\w+/
str = '#food was testy. #drink lots of. #night was fab. #three #four'
# Print the match result
str.match(re) do |match|
puts match.to_s
end