using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!:)(?= \d)";
string substitution = @":";
string input = @"width 40cm height 70cm something: 1234";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}