re = /(?<!:)(?= \d)/
str = 'width 40cm height 70cm something: 1234'
subst = ':'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result