$re = '/(?<!:)(?= \d)/';
$str = 'width 40cm height 70cm something: 1234';
$subst = ":";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;