using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>\d+|[A-Z][a-z]*|[a-z]+)(?!$)";
string substitution = @"$0-";
string input = @"foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}