import Foundation
let pattern = #"(?>\d+|[A-Z][a-z]*|[a-z]+)(?!$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)