using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a [^>]*>\K[^<]*(?=<\/a>)";
string input = @"<a href=""names.php?action=names&name=1"">jehan</a>
<a href=""names.php?action=names&name=2"">roy</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}