$re = '/<a [^>]*>\K[^<]*(?=<\/a>)/m';
$str = '<a href="names.php?action=names&name=1">jehan</a>
<a href="names.php?action=names&name=2">roy</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);