re = /<a [^>]*>\K[^<]*(?=<\/a>)/m
str = '<a href="names.php?action=names&name=1">jehan</a>
<a href="names.php?action=names&name=2">roy</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end