$re = '/\$\{(.*?)\}/';
$str = '${FNAME} ${LNAME} ${123}';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;