import re
regex = re.compile(r"\$\{(.*?)\}")
test_str = "${FNAME} ${LNAME} ${123}"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)