using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"from IP=(?P<IP>[^:]+?).*?\(IP=(?P<IP_2>[^:])";
string input = @"Dec 15 10:13:27 ldap1 slapd[50625]: conn=12341234 fd=207 ACCEPT from IP=192.168.1.111:34792 (IP=0.0.0.0:389)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}