package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`from IP=(?P<IP>[^:]+?).*?\(IP=(?P<IP_2>[^:])`)
var str = `Dec 15 10:13:27 ldap1 slapd[50625]: conn=12341234 fd=207 ACCEPT from IP=192.168.1.111:34792 (IP=0.0.0.0:389)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}