re = /from IP=(?P<IP>[^:]+?).*?\(IP=(?P<IP_2>[^:])/
str = 'Dec 15 10:13:27 ldap1 slapd[50625]: conn=12341234 fd=207 ACCEPT from IP=192.168.1.111:34792 (IP=0.0.0.0:389)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end