# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+/\d+/\d+"
test_str = ("interface gpon_olt-1/1/1 onu 1 type ZTE-OMC3 sn ZTEGC0CD5938\n"
"interface gpon_olt-1/1/1 onu 2 type ZTE-F612 sn ZTEGC8BF978F\n"
"interface gpon_olt-1/1/1 onu 3 type ZTE-OMC3 sn ZTEGC8653DA1\n"
"interface gpon_olt-1/1/1 onu 4 type ZTE-OMC3 sn ZTEGC4BC9D80\n"
"interface gpon_olt-1/1/1 onu 5 type ZTE-F670 sn ZTEGCE8DA5F5\n"
"interface gpon_olt-1/1/1 onu 7 type ZTE-F670 sn ZTEGC8509BBE\n"
"interface gpon_olt-1/1/1 onu 8 type ZTE-F670 sn ZTEGC8B65274")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.