import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<ip>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}) (?P<domain>[^ ]+) \\- \\[(?P<datetime>\\d{2}\\/[a-zA-Z]{3}\\/\\d{4}:\\d{2}:\\d{2}:\\d{2} (?:\\+|\\-)\\d{4})\\] \"(?P<method>\\w+) (?P<url>[^ ]+) (?P<proto>[^ ]+)\" (?P<status>\\d+) (?P<bytes>\\d+)";
final String string = "210.71.248.160 hinetcdn.1000101720.tw.gamesbean.net - [15/Oct/2015:10:00:57 +0800] \"GET /HiNet-IDCCDN_Service_Test_File.txt HTTP/1.1\" 200 23 \"-\" \"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36\" \"-\" \"0.000\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}