import Foundation
let pattern = #"(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}) (?P<domain>[^ ]+) \- \[(?P<datetime>\d{2}\/[a-zA-Z]{3}\/\d{4}:\d{2}:\d{2}:\d{2} (?:\+|\-)\d{4})\] "(?P<method>\w+) (?P<url>[^ ]+) (?P<proto>[^ ]+)" (?P<status>\d+) (?P<bytes>\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"210.71.248.160 hinetcdn.1000101720.tw.gamesbean.net - [15/Oct/2015:10:00:57 +0800] "GET /HiNet-IDCCDN_Service_Test_File.txt HTTP/1.1" 200 23 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36" "-" "0.000""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}