const regex = /(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}) (?P<domain>[^ ]+) \- \[(?P<datetime>\d{2}\/[a-zA-Z]{3}\/\d{4}:\d{2}:\d{2}:\d{2} (?:\+|\-)\d{4})\] "(?P<method>\w+) (?P<url>[^ ]+) (?P<proto>[^ ]+)" (?P<status>\d+) (?P<bytes>\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<ip>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}) (?P<domain>[^ ]+) \\- \\[(?P<datetime>\\d{2}\\\/[a-zA-Z]{3}\\\/\\d{4}:\\d{2}:\\d{2}:\\d{2} (?:\\+|\\-)\\d{4})\\] "(?P<method>\\w+) (?P<url>[^ ]+) (?P<proto>[^ ]+)" (?P<status>\\d+) (?P<bytes>\\d+)', '')
const str = `210.71.248.160 hinetcdn.1000101720.tw.gamesbean.net - [15/Oct/2015:10:00:57 +0800] "GET /HiNet-IDCCDN_Service_Test_File.txt HTTP/1.1" 200 23 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36" "-" "0.000"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}