using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^;]+; )+([^;]+); ([^;]+);$";
string input = @"00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}