$re = '/^(?:[^;]+; )+([^;]+); ([^;]+);$/';
$str = '00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);