// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:[^;]+; )+([^;]+); ([^;]+);$").unwrap();
let string = "00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}