#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<b>(.*?)<\/b>"
Local $sString = "<b> GALADRIEL (V.O.)" & @CRLF & _
"</b> (Elvish: subtitled)" & @CRLF & _
" "I amar prestar sen: han mathon ne nen," & @CRLF & _
" han mathon ne chae...a han noston ned" & @CRLF & _
" wilith."" & @CRLF & _
" (English:)" & @CRLF & _
" The world is changed: I feel it in the" & @CRLF & _
" water, I feel it in the earth, I smell it" & @CRLF & _
" in the air...Much that once was is lost," & @CRLF & _
" for none now live who remember it." & @CRLF & _
"" & @CRLF & _
"<b>SUPER: THE LORD OF THE RINGS" & @CRLF & _
"</b>" & @CRLF & _
"<b>EXT. PROLOGUE -- DAY" & @CRLF & _
"</b>" & @CRLF & _
"IMAGE: FLICKERING FIRELIGHT. The NOLDORIN FORGE in EREGION." & @CRLF & _
"MOLTEN GOLD POURS from the lip of an IRON LADLE." & @CRLF & _
"" & @CRLF & _
"<b> GALADRIEL (V.O.)" & @CRLF & _
"</b> It began with the forging of the Great" & @CRLF & _
" Rings." & @CRLF & _
"" & @CRLF & _
"IMAGE: THREE RINGS, each set with a single GEM, are received" & @CRLF & _
"by the HIGH ELVES-GALADRIEL, GIL-GALAD and CIRDAN." & @CRLF & _
"" & @CRLF & _
"<b> GALADRIEL (V.O.) (CONT'D)" & @CRLF & _
"</b> Three were given to the Elves, immortal," & @CRLF & _
" wisest...fairest of all beings." & @CRLF & _
"" & @CRLF & _
"IMAGE: SEVEN RINGS held aloft in triumph by the DWARF LORDS." & @CRLF & _
"" & @CRLF & _
"<b> GALADRIEL (V.O.) (CONT'D)" & @CRLF & _
"</b> Seven to the Dwarf Lords, great miners" & @CRLF & _
" and craftsmen of the mountain halls." & @CRLF & _
"" & @CRLF & _
"IMAGE: NINE RINGS clutched tightly by the KINGS OF MEN...as" & @CRLF & _
"if holding-close a precious secret." & @CRLF & _
"" & @CRLF & _
"<b> GALADRIEL (V.O.) (CONT'D)" & @CRLF & _
"</b> And Nine...nine rings were gifted to the" & @CRLF & _
" race of Men who, above all else, desire" & @CRLF & _
" power." & @CRLF & _
"<b> (MORE)" & @CRLF & _
"</b>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")