import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<b>(.*?)<\\/b>";
final String string = "<b> GALADRIEL (V.O.)\n"
+ "</b> (Elvish: subtitled)\n"
+ " \"I amar prestar sen: han mathon ne nen,\n"
+ " han mathon ne chae...a han noston ned\n"
+ " wilith.\"\n"
+ " (English:)\n"
+ " The world is changed: I feel it in the\n"
+ " water, I feel it in the earth, I smell it\n"
+ " in the air...Much that once was is lost,\n"
+ " for none now live who remember it.\n\n"
+ "<b>SUPER: THE LORD OF THE RINGS\n"
+ "</b>\n"
+ "<b>EXT. PROLOGUE -- DAY\n"
+ "</b>\n"
+ "IMAGE: FLICKERING FIRELIGHT. The NOLDORIN FORGE in EREGION.\n"
+ "MOLTEN GOLD POURS from the lip of an IRON LADLE.\n\n"
+ "<b> GALADRIEL (V.O.)\n"
+ "</b> It began with the forging of the Great\n"
+ " Rings.\n\n"
+ "IMAGE: THREE RINGS, each set with a single GEM, are received\n"
+ "by the HIGH ELVES-GALADRIEL, GIL-GALAD and CIRDAN.\n\n"
+ "<b> GALADRIEL (V.O.) (CONT'D)\n"
+ "</b> Three were given to the Elves, immortal,\n"
+ " wisest...fairest of all beings.\n\n"
+ "IMAGE: SEVEN RINGS held aloft in triumph by the DWARF LORDS.\n\n"
+ "<b> GALADRIEL (V.O.) (CONT'D)\n"
+ "</b> Seven to the Dwarf Lords, great miners\n"
+ " and craftsmen of the mountain halls.\n\n"
+ "IMAGE: NINE RINGS clutched tightly by the KINGS OF MEN...as\n"
+ "if holding-close a precious secret.\n\n"
+ "<b> GALADRIEL (V.O.) (CONT'D)\n"
+ "</b> And Nine...nine rings were gifted to the\n"
+ " race of Men who, above all else, desire\n"
+ " power.\n"
+ "<b> (MORE)\n"
+ "</b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}