# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<b>(.*?)<\/b>"
test_str = ("<b> GALADRIEL (V.O.)\n"
"</b> (Elvish: subtitled)\n"
" \"I amar prestar sen: han mathon ne nen,\n"
" han mathon ne chae...a han noston ned\n"
" wilith.\"\n"
" (English:)\n"
" The world is changed: I feel it in the\n"
" water, I feel it in the earth, I smell it\n"
" in the air...Much that once was is lost,\n"
" for none now live who remember it.\n\n"
"<b>SUPER: THE LORD OF THE RINGS\n"
"</b>\n"
"<b>EXT. PROLOGUE -- DAY\n"
"</b>\n"
"IMAGE: FLICKERING FIRELIGHT. The NOLDORIN FORGE in EREGION.\n"
"MOLTEN GOLD POURS from the lip of an IRON LADLE.\n\n"
"<b> GALADRIEL (V.O.)\n"
"</b> It began with the forging of the Great\n"
" Rings.\n\n"
"IMAGE: THREE RINGS, each set with a single GEM, are received\n"
"by the HIGH ELVES-GALADRIEL, GIL-GALAD and CIRDAN.\n\n"
"<b> GALADRIEL (V.O.) (CONT'D)\n"
"</b> Three were given to the Elves, immortal,\n"
" wisest...fairest of all beings.\n\n"
"IMAGE: SEVEN RINGS held aloft in triumph by the DWARF LORDS.\n\n"
"<b> GALADRIEL (V.O.) (CONT'D)\n"
"</b> Seven to the Dwarf Lords, great miners\n"
" and craftsmen of the mountain halls.\n\n"
"IMAGE: NINE RINGS clutched tightly by the KINGS OF MEN...as\n"
"if holding-close a precious secret.\n\n"
"<b> GALADRIEL (V.O.) (CONT'D)\n"
"</b> And Nine...nine rings were gifted to the\n"
" race of Men who, above all else, desire\n"
" power.\n"
"<b> (MORE)\n"
"</b>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.