package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\s\S]*Total IDOCs processed: (\S+)`)
var str = ` 2024 Sep 11 19:26:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15705 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:27:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15710 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:28:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15713 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}