# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\s\S]*Total IDOCs processed: (\S+)"
test_str = (" 2024 Sep 11 19:26:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15705 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW\n\n"
"2024 Sep 11 19:27:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15710 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW\n\n"
"2024 Sep 11 19:28:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15713 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.