// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\s\S]*Total IDOCs processed: (\S+)").unwrap();
let string = " 2024 Sep 11 19:26:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15705 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:27:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15710 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:28:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15713 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}