#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!\.git).)*$"
Local $sString = "/" & @CRLF & _
"/git" & @CRLF & _
"/git/" & @CRLF & _
"/gits/" & @CRLF & _
"/gits/stm32/" & @CRLF & _
"/gits/stm32/repo.git/" & @CRLF & _
"/gits/stm32/repo.git/head"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")