import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!\\.git).)*$";
final String string = "/\n"
+ "/git\n"
+ "/git/\n"
+ "/gits/\n"
+ "/gits/stm32/\n"
+ "/gits/stm32/repo.git/\n"
+ "/gits/stm32/repo.git/head";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}