$re = '/^((?!\.git).)*$/m';
$str = '/
/git
/git/
/gits/
/gits/stm32/
/gits/stm32/repo.git/
/gits/stm32/repo.git/head';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);